Administrator Has Blocked This Application From Installing

Administrator Has Blocked This Application From Installing

Case:

You’re trying to install a ClickOnce application and get an error message saying: “Your administrator has blocked this application because it potentially poses a security risk to your computer”:
Your administrator has blocked this application because it potentially poses a security risk to your computer


Cause:

The ClickOnce trust prompt is disabled on your operating system, so instead of a dialog (prompt) which allows you to either proceed with the installation or not, you just get the message above.

Solution:

You can change the trust pompt by editing the registry subkeys under:

\HKEY_LOCAL_MACHINE\SOFTWARE\MICROSOFT\.NETFramework\Security\TrustManager\PromptingLevel

There are five security zones for which you will need to edit the subkey.

Registry trustmanager promptinglevel

Each subkey can have one of the following values:

  1. Disabled: No trust prompt is shown, instead you get the 'Administrator Has Blocked This Application From Installing' error.
  2. Enabled: A trust prompt is shown..
  3. AuthenticodeRequired: A trust prompt is shown only for signed applications (other applications cannot be installed).  It is recomended to set each subkey to 'Enabled'.

Trust prompt example

      


You should now see the trust prompt option in the security warning.  

If additional assistance is still required after performing these steps, please call Verisurf Support at 1-888-713-7201

    • Related Articles

    • Installing Verisurf Learning Edition (VLE) 2025

      Use the following instructions for downloading and installing the free Verisurf Learning Edition (VLE). 1. Download VLE to a location on your computer. 2. When the download completes, go to the computer location of the download and double left mouse ...
    • "Invalid or Corrupt Signature" When Installing Verisurf 2020

      Case: An "Invalid Digital Signature" prompt is receied when installing Verisurf 2017 and up. Cause: Windows 7 or 10 installations that do not have the digital signature verification required for the Verisurf Installation. Solution: The resolution is ...
    • How to load a Universal CMM license

      Dear Verisurf customer, To ensure proper installation and configuration of Universal CMM, please review the following step-by-step guide before beginning the installation. Universal CMM Installation Instructions NOTE: Your organization may require ...
    • How to register the SwDocumentMgr.dll file?

      Case: Cannot find Parasolid data in SoldiWorks file error when trying to open it.  The SwDocumentMgr.dll file must be manually registered. Cause: The SwDocumentMgr.dll file did not register correctly and must be manually registered. Solution: There ...
    • Creating a CMDust log to troubleshoot a broken Software License

      Case: A software license broke for a single seat or a network license, and running the wizard to activate it again fails to complete successfully. Cause: One of the hardware or software binding pieces for the license changed, causing the license to ...